具體命令如下:
一、交換機(jī)基本狀態(tài):
- hostname> ;用戶模式
- hostname# ;特權(quán)模式
- hostname(config)# ;全局配置模式
- hostname(config-if)# ;接口狀態(tài)
二、交換機(jī)口令設(shè)置:
- switch>enable ;進(jìn)入特權(quán)模式
- switch#config terminal ;進(jìn)入全局配置模式
- switch(config)#hostname ;設(shè)置交換機(jī)的主機(jī)名
- switch(config)#enable secret xxx ;設(shè)置特權(quán)加密口令
- switch(config)#enable password xxa ;設(shè)置特權(quán)非密口令
- switch(config)#line console 0 ;進(jìn)入控制臺(tái)口
- switch(config-line)#line vty 0 4 ;進(jìn)入虛擬終端
- switch(config-line)#login ;允許登錄
- switch(config-line)#password xx ;設(shè)置登錄口令xx
- switch#exit ;返回命令
三、交換機(jī)VLAN設(shè)置:
- switch#vlan database ;進(jìn)入VLAN設(shè)置
- switch(vlan)#vlan 2 ;建VLAN 2
- switch(vlan)#no vlan 2 ;刪vlan 2
- switch(config)#int f0/1 ;進(jìn)入端口1
- switch(config-if)#switchport access vlan 2 ;當(dāng)前端口加入vlan 2
- switch(config-if)#switchport mode trunk ;設(shè)置為干線
- switch(config-if)#switchport trunk allowed vlan 1,2 ;設(shè)置允許的vlan
- switch(config-if)#switchport trunk encap dot1q ;設(shè)置vlan 中繼
- switch(config)#vtp domain ;設(shè)置發(fā)vtp域名
- switch(config)#vtp password ;設(shè)置發(fā)vtp密碼
- switch(config)#vtp mode server ;設(shè)置發(fā)vtp模式
- switch(config)#vtp mode client ;設(shè)置發(fā)vtp模式
4、交換機(jī)設(shè)置IP地址:
- switch(config)#interface vlan 1 ;進(jìn)入vlan 1
- switch(config-if)#ip address ;設(shè)置IP地址
- switch(config)#ip default-gateway ;設(shè)置默認(rèn)網(wǎng)關(guān)
- switch#dir flash: ;查看閃存
五、交換機(jī)顯示命令:
- switch#write ;保存配置信息
- switch#show vtp ;查看vtp配置信息
- switch#show run ;查看當(dāng)前配置信息
- switch#show vlan ;查看vlan配置信息
- switch#show interface ;查看端口信息
- switch#show int f0/0 ;查看指定端口信息
六、路由器顯示命令:
- router#show run ;顯示配置信息
- router#show interface ;顯示接口信息
- router#show ip route ;顯示路由信息
- router#show cdp nei ;顯示鄰居信息
- router#reload ;重新起動(dòng)
七、路由器口令設(shè)置:
- router>enable ;進(jìn)入特權(quán)模式
- router#config terminal ;進(jìn)入全局配置模式
- router(config)#hostname ;設(shè)置交換機(jī)的主機(jī)名
- router(config)#enable secret xxx ;設(shè)置特權(quán)加密口令
- router(config)#enable password xxb ;設(shè)置特權(quán)非密口令
- router(config)#line console 0 ;進(jìn)入控制臺(tái)口
- router(config-line)#line vty 0 4 ;進(jìn)入虛擬終端
- router(config-line)#login ;要求口令驗(yàn)證
- router(config-line)#password xx ;設(shè)置登錄口令xx
- router(config)#(Ctrl+z) ; 返回特權(quán)模式
- router#exit ;返回命令
八、路由器配置:
- router(config)#int s0/0 ;進(jìn)入Serail接口
- router(config-if)#no shutdown ;激活當(dāng)前接口
- router(config-if)#clock rate 64000 ;設(shè)置同步時(shí)鐘
- router(config-if)#ip address ;設(shè)置IP地址
- router(config-if)#ip address second ;設(shè)置第二個(gè)IP
- router(config-if)#int f0/0.1 ;進(jìn)入子接口
- router(config-subif.1)#ip address ;設(shè)置子接口IP
- router(config-subif.1)#encapsulation dot1q ;綁定vlan中繼協(xié)議
- router(config)#config-register 0x2142 ;跳過(guò)配置文件
- router(config)#config-register 0x2102 ;正常使用配置文件
- router#reload ;重新引導(dǎo)
九、路由器文件操作:
- router#copy running-config startup-config ;保存配置
- router#copy running-config tftp ;保存配置到tftp
- router#copy startup-config tftp ;開機(jī)配置存到tftp
- router#copy tftp flash: ;下傳文件到flash
- router#copy tftp startup-config ;下載配置文件
十、ROM狀態(tài):
十一、靜態(tài)路由:
- ip route ;命令格式
- router(config)#ip route 2.0.0.0 255.0.0.0 1.1.1.2 ;靜態(tài)路由舉例
- router(config)#ip route 0.0.0.0 0.0.0.0 1.1.1.2 ;默認(rèn)路由舉例
十二、動(dòng)態(tài)路由:
- router(config)#ip routing ;啟動(dòng)路由轉(zhuǎn)發(fā)
- router(config)#router rip ;啟動(dòng)RIP路由協(xié)議。
- router(config-router)#network ;設(shè)置發(fā)布路由
- router(config-router)#negihbor ;點(diǎn)對(duì)點(diǎn)幀中繼用。
十三、幀中繼命令:
- router(config)#frame-relay switching ;使能幀中繼交換
- router(config-s0)#encapsulation frame-relay ;使能幀中繼
- router(config-s0)#fram-relay lmi-type cisco ;設(shè)置管理類型
- router(config-s0)#frame-relay intf-type DCE ;設(shè)置為DCE
- router(config-s0)#frame-relay dlci 16 ;
- router(config-s0)#frame-relay local-dlci 20 ;設(shè)置虛電路號(hào)
- router(config-s0)#frame-relay interface-dlci 16 ;
- router(config)#log-adjacency-changes ;記錄鄰接變化
- router(config)#int s0/0.1 point-to-point ;設(shè)置子接口點(diǎn)對(duì)點(diǎn)
- router#show frame pvc ;顯示永久虛電路
- router#show frame map ;顯示映射
十四、基本訪問(wèn)控制列表:
- router(config)#access-list permit|deny
- router(config)#interface ;default:deny any
- router(config-if)#ip access-group in|out ;defaultut
例1:
router(config)#access-list 4 permit 10.8.1.1 router(config)#access-list 4 deny 10.8.1.0 0.0.0.255 router(config)#access-list 4 permit 10.8.0.0 0.0.255.255 router(config)#access-list 4 deny 10.0.0.0 0.255.255.255 router(config)#access-list 4 permit any router(config)#int f0/0 router(config-if)#ip access-group 4 in
擴(kuò)展訪問(wèn)控制列表:
access-list permit|deny icmp [type]
access-list permit|deny tcp [port]
例2:
router(config)#access-list 101 deny icmp any 10.64.0.2 0.0.0.0 echo router(config)#access-list 101 permit ip any any router(config)#int s0/0 router(config-if)#ip access-group 101 in
例3:
router(config)#access-list 102 deny tcp any 10.65.0.2 0.0.0.0 eq 80 router(config)#access-list 102 permit ip any any router(config)#interface s0/1 router(config-if)#ip access-group 102 out
十五、刪除訪問(wèn)控制例表:
- router(config)#no access-list 102
- router(config-if)#no ip access-group 101 in
十六、路由器的nat配置:
- Router(config-if)#ip nat inside ;當(dāng)前接口指定為內(nèi)部接口
- Router(config-if)#ip nat outside ;當(dāng)前接口指定為外部接口
- Router(config)#ip nat inside source static [p] [port]
- Router(config)#ip nat inside source static 10.65.1.2 60.1.1.1
- Router(config)#ip nat inside source static tcp 10.65.1.3 80 60.1.1.1 80
- Router(config)#ip nat pool p1 60.1.1.1 60.1.1.20 255.255.255.0
- Router(config)#ip nat inside source list 1 pool p1
- Router(config)#ip nat inside destination list 2 pool p2
- Router(config)#ip nat inside source list 2 interface s0/0 overload
- Router(config)#ip nat pool p2 10.65.1.2 10.65.1.4 255.255.255.0 type rotary
- Router#show ip nat translation
rotary 參數(shù)是輪流的意思,地址池中的IP輪流與NAT分配的地址匹配。
overload參數(shù)用于PAT 將內(nèi)部IP映射到一個(gè)公網(wǎng)IP不同的端口上。
十七、外部網(wǎng)關(guān)協(xié)議配置:
- routerA(config)#router bgp 100
- routerA(config-router)#network 19.0.0.0
- routerA(config-router)#neighbor 8.1.1.2 remote-as 200
十八、配置PPP驗(yàn)證:
- RouterA(config)#username password
- RouterA(config)#int s0
- RouterA(config-if)#ppp authentication {chap|pap}
文章名稱:匯總思科三層交換機(jī)配置命令大全
網(wǎng)頁(yè)鏈接:http://www.rwnh.cn/news/104950.html
成都網(wǎng)站建設(shè)公司_創(chuàng)新互聯(lián),為您提供網(wǎng)站導(dǎo)航、云服務(wù)器、企業(yè)網(wǎng)站制作、網(wǎng)站排名、App開發(fā)、網(wǎng)站設(shè)計(jì)
廣告
聲明:本網(wǎng)站發(fā)布的內(nèi)容(圖片、視頻和文字)以用戶投稿、用戶轉(zhuǎn)載內(nèi)容為主,如果涉及侵權(quán)請(qǐng)盡快告知,我們將會(huì)在第一時(shí)間刪除。文章觀點(diǎn)不代表本網(wǎng)站立場(chǎng),如需處理請(qǐng)聯(lián)系客服。電話:028-86922220;郵箱:631063699@qq.com。內(nèi)容未經(jīng)允許不得轉(zhuǎn)載,或轉(zhuǎn)載時(shí)需注明來(lái)源:
創(chuàng)新互聯(lián)